Script pour CO Fantasy sous Roll20 2255

Forums > Jeux de rôle > JdR Black Book > Chroniques Oubliées

avatar

Bonjour Ulti

j'ai 2 questions pour toi

> j'utilise Pacifisme sur une moine, j'ai bien rajouter pacifisme et valeur 5 en max, mais je viens de faire plusieurs essais et je n'arrive pas à le faire fonctionner

Tu as aussi mis 5 en valeur courante ? Ou sinon, tu peux commencer un combat et le terminer, ça remet la valeur courante à 5. Enfin, autre possibilité, es-tu sûr que ton attribut est bien 'pacifisme', sans espace à la fin ?

> en role play, un joueur prend feu car il recoit une fleche enflamée, il decide de se rouler dans l'herbe pour éteindre le feu, comment puis je stopper l'effet en tant que MJ ?

merci encore pour ton aide

Tenefir

Il s'agit d'un sort de flèche enflammée ? Si oui, il fait supprimer l'attribut 'enflamme' de ton joueur. C'est pas très pratique, mais je n'avais pas pensé qu'on pouvait se débarasser de ce feu, qui, selon mon interprétation, est magique.

Ce message a reçu 1 réponse de
  • Tenefir
avatar
Ulti

merci, pour le feu, je vais enlever l'attribut, c'est pas un souci

pour pacifisme j'ai : pacifisme 5/5 (pas d'espace ou autre)

je lance un début de combat, le moine à l'init, je le passe sans faire d'action

un gobelin attaque, le moine à une def de 15 qui devrait passé à 20, mais dés le 1er tour j'arrive à le toucher en dessous de 20

j'ai pu voir aussi dansle code tu avais des alertes en fin de combat pour récupérer pacifisme, et je ne les ai pas

voilà je sais pas si ça t'aide

Ce message a reçu 1 réponse de
  • Ulti
avatar
Tenefir

Non, j'avoue que ça n'aide pas. Je viens de ré-essayer, et tout marche bien dans mes jeux. Si tu veux, je peux regarder ta partie, parce que là, je ne vois plus ce qui pourrait poser problème...

Ce message a reçu 1 réponse de
  • Tenefir
avatar
Ulti

j'ai compri, il faut que je mette pacifisme_nomdupersonnage

Ce message a reçu 1 réponse de
  • Ulti
avatar
Tenefir

Ah, je croyais que c'était pour un personnage joueur !

avatar
Ulti

Je viens de ré essayé et ca ne le fait plus du coup je ne me l'explique pas ^^ j'avais pourtant dl la version le jour même comme à chaque fois que je touche la partie, je les lance via les ability sur le token j'utilise jamais les autres méthodes ^^. J'ai quand même remis à jour aujourd'hui le script c'était peut-être là cause quand même, merci ulti !

avatar

Bonjour,

Chose érange ce matin quand j'ai voulu relancé ma campagne. Tout ce déroule normalement à l'ouverture mais rien ne se passe quand le lance ue commande dans le chat.

aucune macro du script ne fonctionne, rien ne s'affiche dans le chat...

J'ai réinstallé le script, cela ne change rien.

J'ai essayé d'ouvrir une ancienne partie et là tout fonctionne normalement.

Vous avez une idée ?

Merci à vous

avatar

C'est la même version du script dans les deux parties ?

Ce message a reçu 1 réponse de
  • krog
avatar
Ulti

Bonjour,

oui la version 2.09

Krog

Ce message a reçu 1 réponse de
  • krog
avatar
krog

Dans la console j'ai ce message :

API sandbox shutdown due to campaign inactivity.

si cela peut aider

avatar

Ça, ça veut juste dire que personne n'est connecté à cette partie. Connecte toi depuis un autre onglet et tu verras le message de chargement du script.

Ce message a reçu 1 réponse de
  • krog
avatar
Ulti

j'ai tenté mais toujours le message. Il n'y a vraiment que cette partie qui me fait cela les autres tout fonctionne. Etrange

Ce message a reçu 1 réponse de
  • TricheLumiere
avatar

Tu es sûr de regarder la Sandow API de la bonne partie ? Si oui, je crois que tu pourrais signaler le bug à Roll20.

Ce message a reçu 1 réponse de
  • krog
avatar
Ulti

Merci Ulti,

je vais fait çà. Je vous tiendrais au courant.

Krog

avatar
krog

Normalement il y a un bouton bleu Restart API Sandbox au dessus de la console qui t'affiche ce message. Ca fait quelque chose quand tu cliques dessus ?

Ce message a reçu 1 réponse de
  • krog
avatar

Bonjour,
J'essaye de mettre une nouvelle image pour l'initiative dynamique pour un token en particulier mais je n'y arrive pas.
J'ai suivi les instructions du doc à la lettre et dans les GM notes voilà ce que j'ai mis :
init_aura:https://s3.amazonaws.com/files.d20.io/images/167150849/2gQJaOIKIkoFr6pjeA598A/med.png?1601189012

l'url du Token semble correcte mais dans le chat COF m'affiche le message suivant :
COFantasy:Image locale de Werro Magestrum incorrecte (https://s3.amazonaws.com/files.d20.io/images/167150849/2gQJaOIKIkoFr6pjeA598A/med.png?1601189012)

Je ne sais pas vraiment quoi faire
Merci d'avance pour vos réponses,

Ce message a reçu 1 réponse de
  • Ulti
avatar
Plaguis

Tout est dans le lien qui explique le format valide (donné dans la documentation du script): 3ème item, on indique que pour les tokens, il faut utiliser la taille "thumb". Dans ton cas, il faudrait donc utiliser l'url

:https://s3.amazonaws.com/files.d20.io/images/167150849/2gQJaOIKIkoFr6pjeA598A/thumb.png?1601189012

Ce message a reçu 1 réponse de
  • Plaguis
avatar
Ulti

J'avais déjà essayer et même en réessayant avant ton lien le même message s'affiche.
EDIT : finalement en copiant le lien dans la barre d'adresse après l'avoir ouvert cela fonctionne.

avatar
TricheLumiere

Non pas de changement.

Apparemment je ne suis pas un cas isolé quand je regarde sur le forum de roll 20

avatar

Bonjour,
Message d'erreur après avoir mis à jour le script : "SyntaxError: Unexpected end of input"
Même après plusieurs restart le message s'affiche à nouveau.
Ce n'est pas urgent je voulais juste signaler cela.