logiciel de création de perso 101

Forums > Jeux de rôle > JdR Black Book > Chroniques Oubliées Casus

avatar

Hola !
Je viens de réaliser qu'il y a un forum pour partager ses aides de jeux chroniques oubliées.
Alors j'en ressort une pas très fraiche d'un tiroir, des fois que ca intéresse du monde: un petit logiciel de création de perso à la va vite.
J'y ai pas touché depuis bien longtemps, à part il y a deux mois quand je l'ai remis sur github (il était sur gitorious bien avant) et que j'ai changé un truc ou deux pour que ca compile sur avec qt5.
Pour compiler:
qmake CO.pro
make
./co-creator
Et théorie ca tourne sous linux/mac/windows. En pratique sous ca n'a été testé que sous linux.

EDIT: oh tiens, j'en avais déja parlé dans le forum "boite d'initiation", je perds la mémoire avec l'age....

avatar

Bonjour,

super initiative, mais un petit tuto/doc pour expliquer que faire des sources ca serait pas mal ! content

avatar

Il faut d'abord avoir un environnement de compilation Qt fonctionnel, ce qui dépends un peu de la plateforme utilisée.

Sur ubuntu/debian, je pense que la commande suivante devrait installer tout ce qui est necessaire:

$ sudo apt-get install qt5-default qt5-qmake qt5-doc-html cmake qt5-qmltooling-plugins qttools5-dev-tools libqt5webkit5-dev libqt5svg5-dev qtbase5-dev

Ensuite, récuperrer les sources:
https://github.com/pierre-amadio/co-character-generator/archive/master.zip


Preparer le Makefile qui va bien avec le Qt installé localement:
$ qmake CO.pro

Lancer la compilation elle même:
$ make

Lancer l'executable:
./co-creator


Si ca ne compile pas avec la version de QT de ta distribution, il est toujours possible d'installer la derniere dans un coin avec l'IDE complet: (cf https://www.qt.io/qt-features-libraries-apis-tools-and-ide/#ide)

$ wget http://download.qt.io/official_releases/online_installers/qt-unified-linux-x64-online.run
$ chmod +x qt-unified-linux-x64-online.run
$ ./qt-unified-linux-x64-online.run

Et ensuite d'utiliser le qmake de cette installation pour preparer le makefile!
$ /home/share/Qt/5.11.1/gcc_64/bin/qmake CO.pro
$ make

avatar

Euh... Un truc pour les utilisateurs lambda qui ne captent rien au technoblabla ci-dessus, c'est envisageable ? Parce que en l'état, c'est aussi exploitable pour moi que les pions cartonnés de la boite COF d'extension "Vengeance" : c'est à dire en rêve seulement pour l'instant !

Ce message a reçu 1 réponse de
  • Melmoth33860
avatar
Mahar

Mahar, je devrait pouvoir préparer un binaire pour une distribution linux à laquelle j'ai accès (ubuntu 16.04 qui traine encore dans un coin, debian stable, RHEL7) durant le week end. Pour une autre distrib, c 'est aussi possible si tu me dis laquelle (mais il va falloire que je l'installe dans une vm et tout et tout, aucune idée de quand je pourrais le faire, mais c'est possible).

Je n'ai pas accès à des machines windows ni mac, et ne compte pas regarder comment on compile des chose dessus.

avatar

Je pense qu'il n'y a pas tant que ça de bi-classés roliste/programmateur programmeur !

Ce message a reçu 1 réponse de
  • Ethariel
avatar
Boze

Par pitié : programmeur content

Ce message a reçu 1 réponse de
  • Boze
avatar
Ethariel

Rhôôô... ça confirme ce que je dis !

Je corrige !

avatar

J'ai mis des binaires pour Ubuntu 16.04 et Debian Stretch sur une page web .

Je ne suis pas vraiment progammeur développeur, et vous aurez remarqué que je ne suis pas graphiste non plus....

Si il y a un volontaire pour compiler ça sous windows, Max OS, ou une distrib linux exotique, faites moi signe.

Ahhh, et pareil si il y a un graphiste qui sait faire de jolis dessins de dés content

Ce message a reçu 1 réponse de
  • Sauriak
avatar
Melmoth33860

La version ubuntu renvoit vers une page 404. clin d'oeil

avatar

Je pense c'est une solution d'hebergement gerée par des lutins qui ont une dent contre ubuntu.... Ils m'enlevent le fichier du ftp sans rien me dire si le nom du fichier contient "ubuntu". Je l'ai renommé, ça à l'air de mieux passer. (Attention c'est la 16.04, pas la toute dernière LTS, c'est possible que ca marche sur 18.04 avec ce binaire mais j'ai comme un doute)

Ce message a reçu 1 réponse de
  • MRick
avatar
Melmoth33860

Je crois que ça aussi ça mérite un peu de traduction :

LTS ce sont les versions d'Ubuntu stables et supportées longtemps (5 ans si mes souvenirs sont exacts). Il n'en sort une nouvelle que les année paires, toujours au mois d'Avril.

La 16.04 est donc sortie en Avril 2016 contre Avril 2018 pour la 18.04. Elles portent aussi des jolis nom comme The Trusty Tahr (le Bélier Confiant), ou The Xenial Xerus (le Xerus Hospitalier), pour ceux qui n'ont pas la mémoire des chiffres.

Les autres versions d'Ubuntu sont des versions pour les développeurs et pour les bidouilleurs, donc si vous avez eu besoin de lire cette traduction, vous pouvez les oublier. plaisantin

avatar

Y'aurait pas une ou deux petites captures d'écran de l'appli pour nous mettre l'eau à la bouche et savoir si ça vaut le coup de s'installer tout l'environnement de dév pour la compiler ? mort de rire

Ce message a reçu 1 réponse de
  • Melmoth33860
avatar
Nioux

screenshot par là

avatar

Bonsoir,

Je viens de mettre en ligne un générateur de fiche de personnage encore quelque peu expérimental, je prévois d'ajouter différente fiche histoire de varier les gouts et les plaisirs.

ça se passe par ici : http://nooblieeschroniques.fr/fiche-perso.php

avatar

Ca a l'air chouette ! Un petit référencement sur la Scénariothèque ?

avatar

Merci bien ! content

avatar

il y a un problème sur les modificateurs de caractéristique raciale, le calcul ne se fait pas sur la caractéristique mais directement sur le modificateur.

Ce message a reçu 1 réponse de
  • NooblieesChroniques
avatar
JeffL

bien vu !!! c'est corrigé ! Ro j'ai honte...

avatar

J'ai fait quelques mises à jour, si vous pouviez faire quelques tests svp, je vous en remerci ~~

Ce message a reçu 1 réponse de
  • Kikooolol42